Failed to retrieve playback terminal

Dec 30, 2014 at 11:30 PM
Hi, I try to play a .wav file in the phone following the outgoing sample example. I get always the error "Failed to retrieve playback terminal". I use Windows 7 x64. I get the same error when I run the AutoAttendant original sample. Is that a problem with the samples, Windows 7, the modem, or ITAPI3 itself? I hope you can help me because I am discouraged after two complete days trying to find a way to play a .wav file in the phone using TAPI.
Dec 30, 2014 at 11:51 PM
Sounds like the TSP + modem combination doesn't support voice. Most modems don't, and even the very few that Microsoft did support were extremely limited. Try a different modem.
Dec 31, 2014 at 3:34 AM
Thank you for your help. The problem was caused by the driver of my modem. I updated it and now this is ok. But I have another problem. How can I play the sound when the called party answer? The state of the call switch to CONNECTED before the answer. Also, when I run the command "playbackTerminal.Start();" manually (with a button) after the answer, I don't hear any sound in the phone. Also in the AutoAttendant sample, it take a very long time before the starting of the playbackTerminal, which do not play the sound after that. An other problem with the modem, or I try to play the sound in the wrong way?
Dec 31, 2014 at 6:18 PM
That's expected. Modems often cannot determine when the remote party answers - there's no way to reliably do that on POTS systems, it requires an intelligent switch and access to the SS7 signals (which the modem does not have). Therefore, Microsoft "cheats" and just transitions to CONNECTED after a few seconds of ringing. AFAIK there's nothing you can do about this but I'd check with the vendor to be certain.

I have to admit that I never used modems - I was always lucky enough to have access to more sophisticated hardware.
Dec 31, 2014 at 7:09 PM
Ok, and can I detect if the called presses a button on his phone?
Dec 31, 2014 at 8:23 PM
Depends on the driver :) TAPI supports it.. many modems did not. You should be able to check the line device capabilities to determine if the TSP says it will report digits.
Dec 31, 2014 at 9:01 PM
Ok, I found how to detect digits and that's work. Thank you very much for your help anf I will try to solve my sound problem.
Feb 12, 2015 at 4:53 PM
Edited Feb 12, 2015 at 9:32 PM
How do we know what type of modem or driver to use or install?
I have a UBS-FAX which used the default windows driver and it works with dialer.exe and the windows fax (WFS.exe), however (not surprisingly) I get "Failed to retrieve playback terminal". It does come with a disk of different drives (CX-FU02, CX-FU02 + , FU06 + \Agere Modem, FU07, and PCIE Modem).

Do you think any of theses would do the trick or can you suggest a better modem or what to look for?


P.S. ATAPI recognizes my modem as: Conexant USB CX93010 ACF Modem which I gather is this:
USB Modem with 4th Gen SmartDAA
Speed: 2400, 14400, 36000, 56000
Host Interface: USB
DAA: SmartDAA 4
Protocols: Point-of-Sale, Alarm
Feb 24, 2015 at 10:46 PM
Edited Feb 25, 2015 at 6:34 AM
Maybe this be useful.
It is modem Driver problem. And this is how i solved.(It worked for me)(