VS 2005, Net framework 2.0 and tapi 3

Jun 28, 2012 at 4:57 PM

I made an application in VS2005 using net framework 2.0 and tapi 2. In xp computers it's working fine. If i try to run this app in win 7 64 bit system there application crashes. I found that the problem was tapi 2. 

Do i have to use Tapi 3?

and if so i tried to use it in VS2005 and i get an error "can't load file 'ITapi3, Version=1.0.0.3, Culture=neutral, PublicKeyToken=36377d9f6f1f4883' "

Where is the problem?

Thanks for help anyway

Coordinator
Aug 17, 2012 at 6:07 PM

You can stay with TAPI 2.0, just mark your application as x86 (the default now in VS2010 and 2012 projects).  Then it runs in 32-bit mode even on 64-bit operating systems which will work just fine.